Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27

Thread: Blown engines

  1. #11
    Casale sells them without the welding BS

  2. #12
    Senior Member HotWater's Avatar
    Join Date
    Mar 2013
    Location
    Clovis, Ca.
    Posts
    361
    We modified this lower cost one. Broached extra 1/4" keyway, machined register, drilled and tapped ce19 pattern. Then I decided to use a River Rat pump and could'nt run this damper lol.Click image for larger version. 

Name:	ImageUploadedByTapatalk1395435737.862867.jpg 
Views:	117 
Size:	68.8 KB 
ID:	36446

  3. #13
    Thats crazy, I've never seen one like that

  4. #14
    Senior Member HotWater's Avatar
    Join Date
    Mar 2013
    Location
    Clovis, Ca.
    Posts
    361
    Quote Originally Posted by K-034 View Post
    Thats crazy, I've never seen one like that
    That first one I posted looked a little sketchy to me which is why I went with something different. I was told that a lot of people used that setup year's ago.

  5. #15
    Casale sold them, may still have some, that didn't have the welded mumbo jumbo..

  6. #16
    I use the ATI balancer on every engine I do and have since about 1992 or so ?
    The make the hubs for me. I bought one of the "Jesel" blower units, looked it over,
    called them asked if they would make the hub to fit a gear drive ( timing chain cover ) ?

    Yep, send us a drawing. Bam , got the hubs.

    Maybe that is how I get away with the stock cranks in the K engines ? ( 1400 hp )

    But, we also made a crank support. I wanted that because I drive the dry sump pump
    off a 8mm belt between the damper (GN7) and the gear drive seal adapter ( RCD ).

    The crank support shaft id double keyed into the ATI hub. We built the first one in 1995.

    The K engine has had the same ATI unit one it, since 2003.
    The backup K engine has had it since 2010.

    http://tribalthunderracing.com/photos/crsp

    If somebody wants more pics , I can take what ever you need.

  7. #17
    Senior Member HotWater's Avatar
    Join Date
    Mar 2013
    Location
    Clovis, Ca.
    Posts
    361
    Quote Originally Posted by wizbang View Post
    I use the ATI balancer on every engine I do and have since about 1992 or so ?
    The make the hubs for me. I bought one of the "Jesel" blower units, looked it over,
    called them asked if they would make the hub to fit a gear drive ( timing chain cover ) ?

    Yep, send us a drawing. Bam , got the hubs.

    Maybe that is how I get away with the stock cranks in the K engines ? ( 1400 hp )

    But, we also made a crank support. I wanted that because I drive the dry sump pump
    off a 8mm belt between the damper (GN7) and the gear drive seal adapter ( RCD ).

    The crank support shaft id double keyed into the ATI hub. We built the first one in 1995.

    The K engine has had the same ATI unit one it, since 2003.
    The backup K engine has had it since 2010.

    http://tribalthunderracing.com/photos/crsp

    If somebody wants more pics , I can take what ever you need.
    Hey Hotdog! Got any pics of that ATI?

  8. #18

  9. #19
    Quote Originally Posted by wizbang View Post
    http://www.atiracing.com/products/da...hubs/index.htm

    http://www.jegs.com/i/ATI/085/918871E/10002/-1

    The ATI website pic shows a couple Ford models with the belt drive area
    Welcome to www.hotboat.com!

  10. #20
    Quote Originally Posted by Hotboat View Post
    Welcome to www.hotboat.com!


    Thank you ,,,, MRS K-034 chewed my ass for not joining !

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •